Jump to content

Resolution greyed out can't change, mini screen even on full screen?


Recommended Posts

As title says, I can't change resolution, all video settings show greyed out, and my screen is a little mini screen, and wont go full screen.

At a loss what to do.  Checked drivers, rebooted....

Any help would be much  appreciated

 

Wow it's been an entire day, over 60 views, and not one person with possible fix.  

I also contact Rockstar support, no help, nice guy but no help.

I also went through a long reinstall but that didn't change a thing.

 

Dam depressing.

I guess I should have just waited for steam version possibly would have been better.

Edited by Kean_1
combined consecutive posts
Link to post
Share on other sites

Hi @Hexton and welcome to the forums.

The reason you may have received 60 views with no responses is simply no one having the answer for you. 

Personally, I would be persistent with R* Support if this is an issue with the game.  I would check the sticky thread occasionally that I created for more updates on hotfixes, solutions, etc. that may be announced.  .....or subscribe to R* Support's Twitter feed so you are kept up to date.  

I wish I could help but I have no idea to be honest.

Link to post
Share on other sites

Ya I new most looking do not know how to fix, or might possibly be experiencing the same as me.

I stated the views because of just how serious my situation is.  

I suppose after a few days I can ask for a refund.  

Hopefully new nvidia drivers again or Rockstar makes a patch happen soon.

I do appreciate the response though. 

  • Like 1
Link to post
Share on other sites

Hi! 

Registered just to help.

I have troubleshooted the problem, pinpointed it and solved it for me, but, spoiler alert, not sure if you will be able to do the same.

So:

My config is a gaming laptop. So it has Itel GPU and external Nvidia GPU.

When you play on the laptops display OR connect the external display via thundrbolt port - the display is driven my Intel GPU and rendering for some apps and RDR2 obviously is done by Nvidia GPU.

And that is where the problem is. Something wrong with this configuration - when display is driven by Intel GPU i get exactly the same problem you have.

 

Now, thankfully, mu laptop also has a HDMI port which hardwarelly conneted to NVIDIA GPU, so when i connect the display throught it - The display is driven by NVIDIA gpu and ALL apps (even chrome, even Excel, everything is rendered by NVIDIA GPU)

 

In this configuratuion - everything works as it should - resolution can be changed and fullscreen is achievable on any resolution - voila.

 

So to resolve the issue you need to drive the display by NVdia GPU only - without INTEL.

  • Thanks 1
Link to post
Share on other sites

So your saying I need to connect to a second screen to have it work through HDMI display?

If it's the display graphics 620, is the issue, I have gone into nvidia control panel and set RDR2 to my 1060gpu (high performance gpu setting).

I have never had an issue like this with any other game.  That the video setting (upper half) are greyed out including resolution is weird. 

Link to post
Share on other sites
57 minutes ago, Hexton said:

 

Quote

So your saying I need to connect to a second screen to have it work through HDMI display?

- Yes, _IF_ your laptop works the same way as mine - that is - that the HDMI port uses only Nvidia GPU, not using Intel 620. My current laptop (MSI GS65) uses NVIDIA when pushing image through HDMI. My previous DELL XPS 9550 - used Intel when pushing image out of HDMI.

Quote

If it's the display graphics 620, is the issue, I have gone into nvidia control panel and set RDR2 to my 1060gpu (high performance gpu setting).

- that won't help you because you set which GPU renders the application and the issue happens when Intel drives the display, regradless of which GPU renders the app. What GPU is used when pushing image through HDMI is hadware defined, most likely you wont be able to change it yourself in software, unless you have some super duper laptop where you can swich which GPU is connected to HDMI, which i am not aware of.

Quote

 I have never had an issue like this with any other game.  That the video setting (upper half) are greyed out including resolution is weird. 

- Well, same here. Obviously it is an issue with the RDR2 + Intel chipsets + Nvidia which Rockstat obviously missed when testing the PC version. I believe they were not testing the case of laptops with Intel gpus + Nvidia gpus altogether, cause it is actually not that typical, although common.

It is ibviosly RockStars fail. Hopefully it is they will figure this out and fix it in future updates.

I tried to post a ticket to support pointing them where the problem is but didin't figure out how to do it. Shows only pre-defined issues to me...

Well anyway they should be able  fix it without my help...

Edited by ElMouse
Link to post
Share on other sites

I do have a laptop as you do.  

I tried turning off my intel 620, believing it would force game to use GPU...that did not work,  game and other issues occurred.   

Unfortunalty I don't have an extra screen (took it to work).

O well, my first experience with Rockstar is a bad one.  Another dam launcher that's useless.  

I just hope Rockstar does fix this issue.

Thanks for the response it at least gave me insight into what is the issue.  

I'll create another ticket later.

Link to post
Share on other sites
7 minutes ago, Hexton said:

I do have a laptop as you do.  

I tried turning off my intel 620, believing it would force game to use GPU...that did not work,  game and other issues occurred.   

Unfortunalty I don't have an extra screen (took it to work).

O well, my first experience with Rockstar is a bad one.  Another dam launcher that's useless.  

I just hope Rockstar does fix this issue.

Thanks for the response it at least gave me insight into what is the issue.  

I'll create another ticket later.

Well i think they will fix it eventually. i dont think the launcher has anything to do with it. it is just the game. They didnt test it after consoles enough to account for all the possible hardware configurations of PC. Yet.

Well, at least they did release RDR2 for PC. they didnt do it with RDR1 still. Which is a huge bummer. RDR1 is masterpiece.

 

Apprently Intel relesed gpu drivers update on 30 of OCT. I thought updating them might help. But, no. Didnt help at all. So... wating for now.

Link to post
Share on other sites
15 hours ago, ElMouse said:

Well, at least they did release RDR2 for PC. they didnt do it with RDR1 still. Which is a huge bummer. RDR1 is masterpiece.

I hope that all PC users will resolve their problems eventually. Its worth to wait bcoz the game is very, very, very good.

A bit off topic from my side.    Played both RDR  games and i have to say that RDR 1 is indeed good but its light years away from RDR 2 gameplay and how big the rdr 2 world is. 

 peace ;) 

Edited by James Hickok_1837
Link to post
Share on other sites
2 hours ago, James Hickok_1837 said:

I hope that all PC users will resolve their problems eventually. Its worth to wait bcoz the game is very, very, very good.

A bit off topic from my side.    Played both RDR  games and i have to say that RDR 1 is indeed good but its light years away from RDR 2 gameplay and how big the rdr 2 world is. 

 peace ;) 

Hi.

I am about 3 hrs into RDR2 and havent playes the console version, so i guess i have yet to see everything.

RDR1 being a masterpice, i realy hope RDR2 is better, cause its 10 years after RDR1 got out

Edited by ElMouse
Link to post
Share on other sites
13 hours ago, Guitarnoize said:

ElMouse,so basically you solved this problem by simply playing on another monitor,right?There is no way you can anyhow make NVIDIA GPU render built in Display?

- exactly right. But that's due to my laptop model. Might not work for everyone. But, _generally_, in _gaming_ laptops, they make hdmi be driven by dedicated gpu.

-Not that I know of.

Edited by ElMouse
Link to post
Share on other sites
On 11/9/2019 at 12:45 AM, Hexton said:

No update yet...still waiting.  I've tried R*Support twice, and still not resolved.  

Still a mini screen in upper corner even with full screen in settings.

Still no love from Rockstar.

I womder if they are aware of the problem at all and are working on it.

Link to post
Share on other sites
5 hours ago, ElMouse said:

Still no love from Rockstar.

I womder if they are aware of the problem at all and are working on it.

All I can suggest is that everyone who has a particular problem should be submitting their own trouble tickets to R* Support and be persistent if you are not getting an answer. 

Link to post
Share on other sites

Well I have tried now numerous times with Rockstar about the issue, this time with my pc dxdiag and photos showing the issue, but all Rockstar support does is send me the same dam copy paste email and that's it.  Instead of fixing the problem here go look at this link that has nothing to do with RDR2 running on your laptop.

 

RDR2GRAPHICSGREY.JPG

RDR2SMALLSCREEN.PNG

Edited by Hexton
Link to post
Share on other sites
6 hours ago, Hexton said:

Well I have tried now numerous times with Rockstar about the issue, this time with my pc dxdiag and photos showing the issue, but all Rockstar support does is send me the same dam copy paste email and that's it.  Instead of fixing the problem here go look at this link that has nothing to do with RDR2 running on your laptop.

 

Wow. 4к 3:2 display, 5gb video memory, what laptop model is that?

Surface something? 

Edited by ElMouse
Link to post
Share on other sites

Hi there, mine encounter the same but it’s fixable in my laptop by changing api to Direct X12>restart> chose full screen. But it make the game crash occasionally and not stable at all. Vulkan is much more stable in mine.  

  • Like 1
Link to post
Share on other sites
19 hours ago, Invader said:

Hi there, mine encounter the same but it’s fixable in my laptop by changing api to Direct X12>restart> chose full screen. But it make the game crash occasionally and not stable at all. Vulkan is much more stable in mine.  

Hi! Good catch!

Actually yes, this also "fixes" the issue for me.

However going fullscreen wuth DX12 makes my FPS drop to 1(!). And not in fulscreen DX12 rendering indeed looks much more glitchy than that of vulkan.

So yeah, rockstar didnt optimize RDR2 for PC enough. All the reviews say basically the same.

So  guess, they need like a half a year more to fix it.

Today there was a patch for 3gb - still no fix for the issue.

Edited by ElMouse
Link to post
Share on other sites
5 minutes ago, ElMouse said:

Hi! Good catch!

Actually yes, this also "fixes" the issue for me.

However going fullscreen wuth DX12 makes my FPS drop to 1(!). And not in fulscreen DX12 rendering indeed looks much more glitchy than that of vulkan.

So yeah, rockstar didnt optimize RDR2 for PC enough. All the reviews say basically the same.

So  guess, they need like a half a year more to fix it.

Today there was a patch for 3gb - still no fix for the issue.

The fix today was for stuttering issues.

  • Like 1
Link to post
Share on other sites
9 hours ago, ElMouse said:

Hi! Good catch!

Actually yes, this also "fixes" the issue for me.

However going fullscreen wuth DX12 makes my FPS drop to 1(!). And not in fulscreen DX12 rendering indeed looks much more glitchy than that of vulkan.

So yeah, rockstar didnt optimize RDR2 for PC enough. All the reviews say basically the same.

So  guess, they need like a half a year more to fix it.

Today there was a patch for 3gb - still no fix for the issue.

Yeah, for one fps issue it’s because of VSync. Try turning of and it will go away. 

  • Thanks 1
Link to post
Share on other sites

I can't change the resolution when I use Vulkan API. I also can't change the output screen. After changing to DirectX12 when I use VSync the entire game menu works in 2 FPS. I have to turn it off to use the game normally. But then, when I load the story mode and for example enter the map whole game freezes and my PC stops responding so I have to turn it off with the power button...

 

Link to post
Share on other sites
On 11/13/2019 at 10:26 AM, Hexton said:

Well I have tried now numerous times with Rockstar about the issue, this time with my pc dxdiag and photos showing the issue, but all Rockstar support does is send me the same dam copy paste email and that's it.  Instead of fixing the problem here go look at this link that has nothing to do with RDR2 running on your laptop.

 

RDR2GRAPHICSGREY.JPG

RDR2SMALLSCREEN.PNG
 

Hi, if you’re okay with playing on 1920x1080 res I’ve a solution that work for me at the moment. Either use DX12 API and risk crashing or change my screen Windows resolution to 1920x1080 while using Vulkan API. It work so far, Vulkan is much more stable in my laptop which has GTX 1060 6 GB, 2560x 1440 res. 

Link to post
Share on other sites

I tried changing to DX12 and with VSync off.     It works and so far playable (resolution 1920x1200), if a bit wonky and not smooth at times.  I have to put fullscreen back on every single time I log into game from a mini sized game with windows bordered.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

LATEST RDR2 NEWS CLIPS

×
×
  • Create New...