Jump to content

Blessed are the Meek Glitch


BuzzinRD
 Share

Recommended Posts

I'm trying to play through "Blessed are the Meek?" in Chapter 2, but I keep running into the same problem. After a certain amount of time, Micah just stops moving, enemies stop shooting, and certain controls become non-responsive (can't switch weapons, heal, loot, etc). In addition, all dialogue stops, nothing story-wise progresses, and weird environmental things start popping up, like a floating rifle. On my first attempt, the winch didn't even remove the prison bars, it just fell to the ground with the bars intact and I was stuck. I've given it 10 or 11 attempts and the furthest I've gotten is just across the first bridge. I even said f-it at one point and tried killing off the sheriff directly, but by the time I walked in the glitch had already occurred so they all just stood there waiting to get shot. I also read somewhere that staying behind Micah might help, but no luck there either.

Another thing to note is that is also seems to be messing with my console's resources (playing on a standard XBOX One). When the glitch occurs, pausing the game just darkens the screen and no side menu appears, so I usually tap the Home button to get out. The longer I wait to tap Home, the more likely I have to have the resulting Home menu lock up as well, which seems odd. I even attempting to shut down my console using the controller had about a 20 second delay.

Any advice would be VERY much appreciated. This game is amazing but it sucks having to relive a time where I'm supposed to help Micah.

Link to comment
Share on other sites

On 12/30/2018 at 5:35 PM, tadp0le said:

Try saving the game in a new file right before you progress to the part you are getting stuck at. For some reasons, some people have had issues with corrupted save files and this usually fixes it.

I had to do this twice throughout the story and I am glad I heard about it. Someone brought it up before may have been on here or on reddit but I was able to finish the missions thanks to doing this.

Link to comment
Share on other sites

Appreciate the responses, folks!

Tadpole's suggestion definitely pointed me in the right direction. The first time I tried it, I got wayyy further than usual. I even got to a point where Micah got killed (which I had hoped would come with a reward or something 😉). During the escape though, the screen locked up. After a restart, thing continued to be buggy.

After another 10 attempts and a bunch of trial and error, I figured it out. It's definitely a 'save file' issue, but what also helped (for some reason) was to complete some side tasks before returning to the mission. Specifically in my case, I rolled back to a fresh save (not an auto-save), skinned a deer, talked to the trapper, and saved someone from wolves before finally completing the mission.

Hopefully this helps anyone else with the same issue. Love this game and I'm glad a little save glitch isn't gonna ruin things.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

LATEST RDR2 NEWS CLIPS

×
×
  • Create New...