Jump to content
  • 0

Why am I not able to play the game I paid for?!



I bought RDR2 a month ago and it was the first time I've experienced such a life filled, huge open world, story driven game and it was Amazing!

Went through the missions without noticing how time flied and got to 50 in-game hours in a couple of days....when disaster struck.

I open my PC one day and start up the game.As the rockstar launcher loads up, my power in the house goess off and the launcher couldn't connect.

Game starts up anyway, but im greeted with a "Activation Required" notice, so I figured its because of the WiFi not working. Decided to wait for the power to come back on and play then.

Power comes back after 2 hours, so I re-boot everything, but this time, with my WiFi working, rockstar game launcher couldn't connect again. Despite me having a really fast (working) WiFi connection, the launcher refused to connect and just displayed a "Launcher is in offline mode" message. Game still starts, but then again, an "Activation Required" message pop's up.

I restarted the launcher and tried again. Didn't work. Tried re-installing the launcher - Uninstalled it, went to the rockstar website, clicked on the menu - Social Club, clicked aaannndd...Nothing! Social club website didn't want to load. I can't even download the launcher at this point!

Read some articles on the internet about the issue, and people suggested the following: Flush DNS, Reset DNS, change DNS IP, disable Firewalls and Anti-virus software, connect to mobile hotspot, use a VPN. NOTHING WORKED FOR ME!!!!!!!!!!!!!!!

I saw some people managed to get it working with one of the above solutions, but I could not for the life of me get the goddamn launcher to work at all!

Next step - Contacting Rockstar

Explained my situation to the person I was chatting with and they were trying to help me, really did and were very kind, but all they were doing were making me repeat the steps I mentioned above. At the end, they "escalated" my case to Email, but that was about it. Didn't get any email from them after that, NOTHING!

If any of you here at this forum have had a similar situation, please help me out. I feel like I've been robbed.

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

It sounds like there’s a problem with your computer. The file may have gotten corrupted at some point, but you saying you uninstalled and reinstalled makes me wonder if it’s a physical issue with your hard drive. If you can, I would suggest taking it to geek squad and having them look at it. If they come up with nothing then you may be SOL for playing it on PC. You may have to start playing it on a console.

Then again, if they find something, you’ll have your answers.


I’m sure there’s people here who know more than I do, especially when it comes to PC gaming, as I’m a console gamer.

All I can really tell you is good luck and I hope you get your issue fixed.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...