Jump to content

[RESOLVED] Mouse cursor all the time SOLVED


Den
 Share

Recommended Posts

There is a problem with annoying mouse cursor during all game process. It's just don't disappearing, moving across the screen everytime.

 

SOLVED.

Found a forum with lots of people with same issue. In my case helped next solution.

 

1. Totally reinstall Rockstar Games Launcher and Social Club (maybe optional)

2. Add to exception to Windows Firewall Rockstar Games Launcher and Social Club

3. Rockstar Games Launcher and Epic Games Store set to run as Administrator

4. In game directory set PlayRDR2.exe compatibility with Windows 8

5. The main thing: totally delete C:\Users\<Username>\Documents\Rockstar Games folder

6. Start game. No more annoying cursor!

IMPORTANT: completing paragraph 5 may cause reset of game progress. I didn't synchronized my cloud saves with local after reinstalling Rockstar Games Launcher. But my progress ended on first chapter, so I didn't lost much.

 

Solution search progress:

1. Looking for any corresponding triggers in options menu - No effect.

2. Changing ingame screen resolution - No effect.

3. Changing fullscreen/windowed mode - No effect.

4. Trying to shutdown Social Club Overlay - No way to be done.

5. Alt-Tab game - No effect.

6. Playing with Xbox gamepad - No effect (!).

7. Video driver update - No effect.

8. Launch as Administrator - No effect.

9. Searching solution in the internet - No effect.

10. Contacting Rockstar support service - No answer.

11. Dancing with tambourine, beating head over the wall, praying, crying - No effect.

 

Thanks for following ideas:

12. Installing old drivers - No effect.

13. Turn off Nvidia overlay - No effect.

14.  Display pointer trails in mouse options - No effect.

 

Maybe someone here? Have any ideas?

Edited by Den
  • Thanks 1
Link to comment
Share on other sites

I was watching a streamer to see what it looked like on pc. He had this issue. He had to uninstall the new drivers & go back to his old ones to remove the mouse cursor. Other people told him to turn off his Nvidia overlay. So he did both.

But that’s the problem with pc, since everyone has different setup. Might work for you & it might not. Good luck with that.

  • Like 1
Link to comment
Share on other sites

1 hour ago, C20Dragon said:

I was watching a streamer to see what it looked like on pc. He had this issue. He had to uninstall the new drivers & go back to his old ones to remove the mouse cursor. Other people told him to turn off his Nvidia overlay. So he did both.

But that’s the problem with pc, since everyone has different setup. Might work for you & it might not. Good luck with that.

Hey! Thanks for useful info!

But...

12. Installing old drivers - No effect.

13. Turn off Nvidia overlay - No effect.

Added to post.

 

My guess - it's Social Club Overlay bug. And paragraph 4. Still waiting reaction of support team.

Edited by Den
Link to comment
Share on other sites

7 minutes ago, Cliffs said:

Do you have both mouse and controller plugged in at same time?

Nope, separate. And together. No matter. Tried Steam controller, XBox controller, together and one by one. And totally unplugged. It's not connection problem, cursor still visible. Paragraph 6.

Link to comment
Share on other sites

4 hours ago, Den said:

My guess - it's Social Club Overlay bug. And paragraph 4. Still waiting reaction of support team.

First, I would suspect R* Support is quite busy sorting teething problems with the PC release. I would expect responses may be a little slower than usual during this time.

When did you contact them anyway?

Link to comment
Share on other sites

39 minutes ago, Kean_1 said:

First, I would suspect R* Support is quite busy sorting teething problems with the PC release. I would expect responses may be a little slower than usual during this time.

When did you contact them anyway?

Well, I don't mean to hurry them up. Sent a message about 26 hours ago. Meanwhile do my best to find solution any other way. It's a pitty to wait a game for a year, then install it, start it and... find a very little, but very annoying bug. Of course their fix will be the best.

Link to comment
Share on other sites

Just now, Den said:

Well, I don't mean to hurry them up. Sent a message about 26 hours ago. Meanwhile do my best to find solution any other way. It's a pitty to wait a game for a year, then install it, start it and... find a very little, but very annoying bug. Of course their fix will be the best.

On normal days, my experience has been that they will typically respond within a couple hours or within 24.  However, their Support site say <48 hours.  I suspect most responses will be within 2 days perhaps a bit more if they are overwhelmed.  Common questions with known answers may get sorted much quicker.  ....who knows.

Hopefully you hear back soon.

Link to comment
Share on other sites

From a different game: Works for some.

 I know you tried Alt/Tab already

 

fixing the bug
1. It is actually very simple, all you have to do when your mouse cursor is in the game is to simple press ALT+TAB and go back to your desktop.
2. ALT+TAB again in to your game once (the game window should be filled with darkness).
3. Use your mouse and move it in to the middle of your screen, if you see it there, that means that the mouse will be visible in game.
4. Move your mouse to the outside of the game screen ( i prefer right edge, don't ask why).
5. click once, move your mouse back in to the middle of the screen. If you dont see your mouse cursor, then you are good to go.
6. ALT+TAB in to your game. if it has not worked repeat from step 1.
  • Thanks 1
Link to comment
Share on other sites

The game worked fine for the first 15 hours then it crashed.

when I restarted the game I had the mouse on screen all time issue.

After looking around all day I found this and it worked for me.

Turn on mouse pointer trails. All the people I found doing this say to make the mouse trails long but I found setting them to short worked as well for me.

That way you can leave them on all the time and you wont go crazy looking at them on desktop.

After you set this you will have to use the back space, arrow keys and enter key to navigate the menus in game.

Mouse Properties 2019-11-09 10_34_26 AM.png

  • Thanks 1
Link to comment
Share on other sites

On 11/6/2019 at 5:37 AM, C20Dragon said:

But that’s the problem with pc, since everyone has different setup. Might work for you & it might not. Good luck with that.

This is what is worrying me. I have not got the game yet, waiting until it comes out for Steam just in case my computer can't handle it.. But I keep seeing everyone having issues with the game that are not easy to solve because most computers when it comes to gaming are not alike. 

Link to comment
Share on other sites

  • Kean_1 changed the title to [RESOLVED] Mouse cursor all the time SOLVED

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

LATEST RDR2 NEWS CLIPS

×
×
  • Create New...