Jump to content

how to activate the game?


Recommended Posts

i bought RDR2 on pre-order on the rockstar site, and i've been playing it since release. i didn't care much about activating it because i was launching from the rockstar launcher and I assumed that it would be ok. unfortunately today they blocked the games and they are asking for an activation and i have no idea how to do that. i already contacted rockstar but usually they take more than 2 months to reply. so... if anyone knows what to do to activate the game, it would be a great help. i already searched my emails and i think that i never received any activation code or instructions to activate the game 😕

btw, i checked my internet connection, tried with 3 different routers and confirmed on my ISP that they are not blocking rockstar games.

Screenshot 2020-02-01 17-35-11.jpg

Link to post
Share on other sites

I've been getting this for the past hour or so [since trying to re-log in after a good exit about 6PM] It even says I'm logged in to Social Club etc - can see my steam connection & everything - whatever it is I think its at R*'s end & not ours - fyi UK PC player if that helps.

Been playing for about 5 hours today, with a few good exits to create solid save points.

I'm about to give up for the day after trying for the last hour-plus to get it working again

Good Luck

Link to post
Share on other sites

i found a few tips on youtube about this, they say to delete the profile. i already did that but nothing changes.

meanwhile i've been waiting on a chat to rockstar support for hours but they keep me in queue without an answer.

while waiting i've been trying everything i can, from deleting all setting files to integrity verification, but i continue to get "activation required" message 😕

i also checked a few forums and facebook but i don't see anyone talking about it. so, i guess that the activation wasn't lost in many accounts.

Link to post
Share on other sites

interesting. it appeared as "pre-purchased" at my end a few times today too.

i'm sorry for you trouble, but i'm more relieved to know that i'm not alone with this problem. maybe there are really a new problem at rockstar end.

Link to post
Share on other sites
1 hour ago, mrohaus said:

I'm finally able to log in after deleting local profile, Give it another try.

 

i already did that... so many times. that and the integrity verification.

one time i managed to reach the menu, but then when i tried to start the game i got a lot of different errors that i never even saw before.

Screenshot 2020-02-01 18-07-24.jpg

Screenshot 2020-02-01 18-07-41.jpg

Screenshot 2020-02-01 18-15-17.jpg

 

UPDATE: i managed to access the game right now, but for the online mode there's only the option to launch on free roam, and it doesn't work, and on story mode they don't allow me to save. so, I guess it was just luck to reach the menu, but the game isn't yet activated :(

 

Screenshot 2020-02-01 21-15-18.jpg

Link to post
Share on other sites
2 hours ago, Sigill MacFinn said:

So I changed nothing, verified nothing, deleted nothing but re-connected about 3 hours later & have played with a solid connection for the past 2 hours - whatever it was it was nothing to do with me 

Hopefully you are having better luck now

yes! seems to be working now but it was clearly something at rockstar end. they always lie in their replies, it's impressive how hateful they are 😕

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

LATEST RDR2 NEWS CLIPS

×
×
  • Create New...